New member 1977 El dorado class C

View previous topic View next topic Go down

New member 1977 El dorado class C

Post  parrothead on Fri Jul 18, 2008 6:01 pm

Boy am I glad I found this place! I just aquired my first RV. 77 El dorado on a Dodge frame.I traded a 76 Camaro for it.The RV came from Wichita Ks.I picked it up in Guthrie Okla (I live in Dallas Ft wth area) The old thing made the 360 mile trip with no problem except when the cover blew off the A/C unit and almost went thru my truck windshield.I was following in the truck.I dont know much about RV,s but this one seems to be well built.And I love anything with a 440 Dodge engine.Of course my first concerns are electrical.The onan generator (3K 25 amp)was running when I picked it up. seller wanted to prove it worked along with the A/C. We shut it off for the trip home.I could not get it to turn over at home.called the seller, told me I had to jump it off.Battery is in a side compartment next to the generator.It had a very small ground cable that goes inside the coach somewhere.So I added a big ground cable directly from the batt to the chassis of the gen.It started right up and I let it run for 2-3 hrs with the A/C on.Then I drove it a couple miles shut the gen off and it hasn't started since! Turns over, wants to start, just doesnt.The gas gauge is showing almost empty (seller doesnt think it reads correctly) so that could be the problem although there was some black smoke coming from the ex pipe when I was trying to start it.Also there is no 12v power in the coach unless the gen is running or its plugged in to shore power.Shouldnt it always have 12v power? which batt supplys this/ the one under the hood or in the side compartment? How does the batt in the side comp get recharged?Well I guess thats enough questions to start with.will probably be many more.Thanks for this site Jeff.

parrothead

Posts : 3
Join date : 2008-07-18

View user profile

Back to top Go down

Re: New member 1977 El dorado class C

Post  parrothead on Fri Jul 18, 2008 7:33 pm

OK,Now this is weird.I worked on that gen for 2-3 hrs the other day.Even took the carb off and cleaned it.It had some brown residue in the bottom of the float bowel.After all this, still wouldnt run. There are 2 batt level indicators.1 in the panel where all the level switches are, just above the kitchen table.This one never shows a reading unless gen is running or RV is plugged in.The 2nd one is in a panel just behind the drivers seat which also houses the gen remote start switch.Just after making my first post. I go in the RV and the one behind the drivers seat has a green reading! So I hit the start switch and the gen fires right up! It stumbled and smoked for a while before smoothing out.sort of. It will run the A/C but it rocks What I mean is the throttle rod or governor maybe with the spring on it will sometimes rock back and forth and the engine RPM will go up and down but not enough to kick the A/C out.There is a adj screw on the bottom of the float bowel that its very sensitive to,but I never got it smoothed completley out.I think I will replace the fuel filter next.Another thing thats surprising is all the 12v power receptacles everywhere.So far I found them by the door,behind the drivers seat,and in the bathroom just ahead of the toilet.Whats up with that? So far my list to get it going is a windsheild wiper motor,Some freon for the dash air,anybody got any R-12? A/C cover,holding tank at the back where all the nasty stuff comes out (can that be patched or sealed?) Repair a couple of faucets,a bunch of outside marker lights,and some cosmetic items.

parrothead

Posts : 3
Join date : 2008-07-18

View user profile

Back to top Go down

Re: New member 1977 El dorado class C

Post  TimKustom on Mon Jul 21, 2008 8:42 am

Hey Parrothead,

Welcome to the group!

I'll try to help you a little with your GenSet. It would be good to know the model of it. Many of the manuals are available by contacting Onan, be persistant though. Most Gensets have a some sort of regulator on them that will not allow them to run if the main tank is below 1/4 of a tank. I'd look into that especially if the gauge isn't reading right.

The "rocking" you describe is most likely "surging." What it is trying to do is regulate the current by a self adjusting throttle. The genset's engine is most likely fine (a little sludge in the carb is normal for something 30 yrs old). It most likely needs the generator part (electrical) commutors, brushes, etc checked or replaced.

Your 12v problem could be bad isolator. You should have two batteries, one for the coach (deep cycle) and one for the truck. I'd make sure both are charged/tested completely, before diving into anything else.

BTW, not to take anything away from this board, but check out www.championfleetowners.org as there is a wealth of knowledge on old rigs (Champions) but they do welcome other brands.
avatar
TimKustom

Posts : 32
Join date : 2008-07-07

View user profile

Back to top Go down

Re: New member 1977 El dorado class C

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum